Email Analytics
Incident Report for Litmus
Resolved
This issue has been resolved.
Posted Feb 29, 2016 - 19:08 EST
Investigating
We are investigating an issue that is causing Email Analytics reports to be delayed. All data is still being collected, but may take more time to show up within your report.
Posted Feb 29, 2016 - 13:05 EST