Issues with some incoming tests
Incident Report for Litmus
Resolved
Everything is back to normal! Thanks for your patience.
Posted May 14, 2015 - 16:30 EDT
Identified
Our team has identified an issue with some incoming email tests. We are working on resolving the issue and should have this fixed shortly.
Posted May 14, 2015 - 15:52 EDT